Website Slow to Load
Incident Report for Uptrust
Identified
In order to speed up website performance and allow Client lists to load properly, the Uptrust engineering team has turned off the Client Dashboard. We will continue to investigate the root cause of the slowness, and turn the Client Dashboard back on when we can ensure loading times will not be adversely impacted.
Posted Oct 23, 2024 - 06:30 PDT
Update
The Uptrust team is continuing to actively investigate slowness on the website as well as Client lists not appearing. This is a top priority; we will provide an update as soon as one is available.
Posted Oct 22, 2024 - 13:39 PDT
Update
We are continuing to investigate this issue.
Posted Oct 21, 2024 - 11:08 PDT
Investigating
We are currently investigating slower loading times on the Uptrust website staff.uptrust.co.
Posted Oct 21, 2024 - 11:07 PDT
This incident affects: Staff Web.